Back
Downtime

Some services are down
Started 24 Mar at 09:57am EDT, resolved 26 Mar at 10:53am EDT.
POP Toronto (ca-toronto-1)
Resolved
Fixed! Thanks for your patience.
Posted 26 Mar at 10:53am EDT.

Created
Toronto POP switched hosts. Downtime was expected, should be back up within 24 hours.
Posted 24 Mar at 09:57am EDT.